Topics

File History No Longer Sees My Toshiba External USB Drive


David Goldfield
 

Using Win10 version 2004.

I have a Toshiba drive connected to a USB port. I should emphasize that this drive is totally available to me via Windows Explorer in that I can see it, open it, access its content and can move files to and from the drive with no issues. In fact, I am using the same drive for Onedrive.

A few months ago I temporarily disconnected the drive. Of course, I eventually received a notification indicating that File History couldn't find the drive and I was advised to reconnect the drive, which I did. I occasionally continued to receive these warnings but as the drive was fully accessible in every other respect I thought it was just Windows making a mistake. Now I find that my files hadn't been backed up since all of that started and File History no longer sees the drive. Here is what I've tried so far.

1. Disconnected and reconnected the drive.

2. Disabled File History and enabled it.

3. Rebooted the PC.


When I enable File History and select a drive the Toshiba drive does not appear in the list.

I'm baffled. I've seen references to this online but so far can't find a fix. Any suggestions as to not only how to fix it but why it happened in the first place?



--
David Goldfield,
Blindness Assistive Technology Specialist
JAWS Certified, 2019

WWW.DavidGoldfield.org


Chris
 

Do a manual backup with the drive connected

 

 

From: David Goldfield
Sent: 06 September 2020 13:13
To: win10@win10.groups.io
Subject: [win10] File History No Longer Sees My Toshiba External USB Drive

 

Using Win10 version 2004.

 

I have a Toshiba drive connected to a USB port. I should emphasize that

this drive is totally available to me via Windows Explorer in that I can

see it, open it, access its content and can move files to and from the

drive with no issues. In fact, I am using the same drive for Onedrive.

 

A few months ago I temporarily disconnected the drive. Of course, I

eventually received a notification indicating that File History couldn't

find the drive and I was advised to reconnect the drive, which I did. I

occasionally continued to receive these warnings but as the drive was

fully accessible in every other respect I thought it was just Windows

making a mistake. Now I find that my files hadn't been backed up since

all of that started and File History no longer sees the drive. Here is

what I've tried so far.

 

1. Disconnected and reconnected the drive.

 

2. Disabled File History and enabled it.

 

3. Rebooted the PC.

 

 

When I enable File History and select a drive the Toshiba drive does not

appear in the list.

 

I'm baffled. I've seen references to this online but so far can't find a

fix. Any suggestions as to not only how to fix it but why it happened in

the first place?

 

 

 

--

David Goldfield,

Blindness Assistive Technology Specialist

JAWS Certified, 2019

 

WWW.DavidGoldfield.org

 

 

 

 


 

David,

           I'm as mystified as you are as to how this came to be, but here's my proposed solution since you say the drive does show up in File Explorer.

1. Plug the drive in and allow it to be recognized by File Explorer.
2. Open Disk Management (if you start entering Disk manager Windows Search the first item returned is "Create and format hard disk partitions," which is actually it.)
3. In the list of disks, find the drive letter for that drive as currently shown in File Explorer.  It's volume name, if you assigned one, will show before the drive letter.
4. With focus on that drive in the list, bring up the context menu and choose the Change drive letter and paths option. When that dialog appears, the current drive letter will already be selected; activate the change button.
5. In the dialog that comes up to let you change, the radio button for change will already be selected, and a dropdown just beyond it will show the current drive letter.  Activate that dropdown and choose another drive letter.  I strongly recommend that you pick something near the upper end of the alphabet that would never be assigned by a random USB drive being plugged in, say T or R or X or Z.  Just something that's not before K, at the very least.  Then get to the OK button and activate it.  OK your way back out to the mane Disk Management window and exit.  You're done with this part.

Afterward, go in to File History and do what's required to change your file history drive, and choose that drive under its new letter.  If it's not visible for that purpose, and under that letter in File History at this point, the mystery deepens significantly.


--

Brian - Windows 10 Pro, 64-Bit, Version 2004, Build 19041

A man's worst difficulties begin when he is able to do as he likes.

       ~ Thomas H. Huxley (1876)


David Goldfield
 

Brian, I appreciate the instructions. I was wondering if changing the drive letter for the Toshiba drive might make a difference but it did not. The drive still does not appear in the list of available drives for File History. It continues to properly function with Windows Explorer as well as OneDrive. My next step will be to do a bit more online research and, beyond that, contacting Microsoft's help desk. Thanks for your efforts, though.

As an aside one of the solutions that worked for someone on one of the online forums had to do with the external drive being listed in a library that was targeted for backup. I think the issue was that he couldn't do this since the source drive and target drive was the same. Off the top of your head do you know where I could look to see if this might be the problem?


David Goldfield,
Blindness Assistive Technology Specialist
JAWS Certified, 2019

WWW.DavidGoldfield.org
On 9/6/2020 12:29 PM, Brian Vogel wrote:

David,

           I'm as mystified as you are as to how this came to be, but here's my proposed solution since you say the drive does show up in File Explorer.

1. Plug the drive in and allow it to be recognized by File Explorer.
2. Open Disk Management (if you start entering Disk manager Windows Search the first item returned is "Create and format hard disk partitions," which is actually it.)
3. In the list of disks, find the drive letter for that drive as currently shown in File Explorer.  It's volume name, if you assigned one, will show before the drive letter.
4. With focus on that drive in the list, bring up the context menu and choose the Change drive letter and paths option. When that dialog appears, the current drive letter will already be selected; activate the change button.
5. In the dialog that comes up to let you change, the radio button for change will already be selected, and a dropdown just beyond it will show the current drive letter.  Activate that dropdown and choose another drive letter.  I strongly recommend that you pick something near the upper end of the alphabet that would never be assigned by a random USB drive being plugged in, say T or R or X or Z.  Just something that's not before K, at the very least.  Then get to the OK button and activate it.  OK your way back out to the mane Disk Management window and exit.  You're done with this part.

Afterward, go in to File History and do what's required to change your file history drive, and choose that drive under its new letter.  If it's not visible for that purpose, and under that letter in File History at this point, the mystery deepens significantly.


--

Brian - Windows 10 Pro, 64-Bit, Version 2004, Build 19041

A man's worst difficulties begin when he is able to do as he likes.

       ~ Thomas H. Huxley (1876)


@BlinkTech
 

Brian:
I wanted to thank you for that explanation as it shows me how to assign a Drive letter to a USB drive. So your explanation was very helpful.
Again thank you so much!



******* Mickey Quenzer *******


From: win10@win10.groups.io <win10@win10.groups.io> on behalf of David Goldfield <david.goldfield@...>
Sent: Sunday, September 6, 2020 1:25:05 PM
To: win10@win10.groups.io <win10@win10.groups.io>
Subject: Re: [win10] File History No Longer Sees My Toshiba External USB Drive
 

Brian, I appreciate the instructions. I was wondering if changing the drive letter for the Toshiba drive might make a difference but it did not. The drive still does not appear in the list of available drives for File History. It continues to properly function with Windows Explorer as well as OneDrive. My next step will be to do a bit more online research and, beyond that, contacting Microsoft's help desk. Thanks for your efforts, though.

As an aside one of the solutions that worked for someone on one of the online forums had to do with the external drive being listed in a library that was targeted for backup. I think the issue was that he couldn't do this since the source drive and target drive was the same. Off the top of your head do you know where I could look to see if this might be the problem?


David Goldfield,
Blindness Assistive Technology Specialist
JAWS Certified, 2019

WWW.DavidGoldfield.org
On 9/6/2020 12:29 PM, Brian Vogel wrote:
David,

           I'm as mystified as you are as to how this came to be, but here's my proposed solution since you say the drive does show up in File Explorer.

1. Plug the drive in and allow it to be recognized by File Explorer.
2. Open Disk Management (if you start entering Disk manager Windows Search the first item returned is "Create and format hard disk partitions," which is actually it.)
3. In the list of disks, find the drive letter for that drive as currently shown in File Explorer.  It's volume name, if you assigned one, will show before the drive letter.
4. With focus on that drive in the list, bring up the context menu and choose the Change drive letter and paths option. When that dialog appears, the current drive letter will already be selected; activate the change button.
5. In the dialog that comes up to let you change, the radio button for change will already be selected, and a dropdown just beyond it will show the current drive letter.  Activate that dropdown and choose another drive letter.  I strongly recommend that you pick something near the upper end of the alphabet that would never be assigned by a random USB drive being plugged in, say T or R or X or Z.  Just something that's not before K, at the very least.  Then get to the OK button and activate it.  OK your way back out to the mane Disk Management window and exit.  You're done with this part.

Afterward, go in to File History and do what's required to change your file history drive, and choose that drive under its new letter.  If it's not visible for that purpose, and under that letter in File History at this point, the mystery deepens significantly.


--

Brian - Windows 10 Pro, 64-Bit, Version 2004, Build 19041

A man's worst difficulties begin when he is able to do as he likes.

       ~ Thomas H. Huxley (1876)


 

David,

           I just want to be absolutely clear, when you open File History, and activate the Select Drive link, when that drive is connected to the computer and visible in File Explorer it is not showing up in the list of available drives?

Mickey,

You're quite welcome.

--

Brian - Windows 10 Pro, 64-Bit, Version 2004, Build 19041

A man's worst difficulties begin when he is able to do as he likes.

       ~ Thomas H. Huxley (1876)


David Goldfield
 

>>when you open File History, and activate the Select Drive link, when that drive is connected to the computer
and visible in File Explorer it is not showing up in the list of available drives?

--

You are absolutely correct. I see system reserved d: and a local drive f:, which are both internal drives.

I can continue accessing the Toshiba drive, now drive t:, from Windows Explorer as well as by entering t: into the run dialog box.

As you say it is very mysterious.

Microsoft Defender is my only security software installed and running.

The external drive, btw, has more than enough space. Windows Explorer reports 1.24 TB free out of 1.36 TB.


David Goldfield,
Blindness Assistive Technology Specialist
JAWS Certified, 2019

WWW.DavidGoldfield.org
On 9/6/2020 3:51 PM, Brian Vogel wrote:

David,

           I just want to be absolutely clear, when you open File History, and activate the Select Drive link, when that drive is connected to the computer and visible in File Explorer it is not showing up in the list of available drives?

Mickey,

You're quite welcome.

--

Brian - Windows 10 Pro, 64-Bit, Version 2004, Build 19041

A man's worst difficulties begin when he is able to do as he likes.

       ~ Thomas H. Huxley (1876)


David Goldfield
 

Just for kicks I temporarily disabled Controlled Folder Access in Defender to see if that might make a difference. It did not.

David Goldfield,
Blindness Assistive Technology Specialist
JAWS Certified, 2019

WWW.DavidGoldfield.org
On 9/6/2020 3:57 PM, David Goldfield wrote:

>>when you open File History, and activate the Select Drive link, when that drive is connected to the computer
and visible in File Explorer it is not showing up in the list of available drives?

--

You are absolutely correct. I see system reserved d: and a local drive f:, which are both internal drives.

I can continue accessing the Toshiba drive, now drive t:, from Windows Explorer as well as by entering t: into the run dialog box.

As you say it is very mysterious.

Microsoft Defender is my only security software installed and running.

The external drive, btw, has more than enough space. Windows Explorer reports 1.24 TB free out of 1.36 TB.


David Goldfield,
Blindness Assistive Technology Specialist
JAWS Certified, 2019

WWW.DavidGoldfield.org
On 9/6/2020 3:51 PM, Brian Vogel wrote:
David,

           I just want to be absolutely clear, when you open File History, and activate the Select Drive link, when that drive is connected to the computer and visible in File Explorer it is not showing up in the list of available drives?

Mickey,

You're quite welcome.

--

Brian - Windows 10 Pro, 64-Bit, Version 2004, Build 19041

A man's worst difficulties begin when he is able to do as he likes.

       ~ Thomas H. Huxley (1876)


 

David,

First Step:  Using SFC (System File Checker) and DISM (Deployment Imaging Servicing and Management) to Repair Windows 8 & 10

Then recheck whether the "lack of recognition" persists.
--

Brian - Windows 10 Pro, 64-Bit, Version 2004, Build 19041

A man's worst difficulties begin when he is able to do as he likes.

       ~ Thomas H. Huxley (1876)


David Goldfield
 

I have fixed the issue where File History was not seeing my external USB hard drive. I did this in a roundabout sort of way without really figuring out the source of the actual problem.

One of the things that I noticed was that the external drive was seen by File History with the other two user accounts on my computer. There was another thing that I noticed which I think was significant in that, with the user accounts which worked properly, the computer played the .wav files one would expect to hear when disconnecting and reconnecting the USB drive. With the account where FH didn't see the drive the .wav files were not heard when disconnecting and reconnecting the drive.

Since I have all of my critical documents properly backed up I decided that the quickest way to get this to work would be to just create another user account and use that one as my day to day account. I did this and FH sees my drive. In fact, doing this also increased performance in other areas, such as slightly improved responsiveness with NVDA and Word 365. I must have had a slightly corrupted profile and using a newly created profile and getting rid of the problematic one was honestly the best thing I probably could have done rather than engaging in even more research which might or might not have led to a solution.



David Goldfield,
Blindness Assistive Technology Specialist
www.DavidGoldfield.org
On 9/6/2020 4:03 PM, David Goldfield wrote:

Just for kicks I temporarily disabled Controlled Folder Access in Defender to see if that might make a difference. It did not.

David Goldfield,
Blindness Assistive Technology Specialist
JAWS Certified, 2019

WWW.DavidGoldfield.org
On 9/6/2020 3:57 PM, David Goldfield wrote:

>>when you open File History, and activate the Select Drive link, when that drive is connected to the computer
and visible in File Explorer it is not showing up in the list of available drives?

--

You are absolutely correct. I see system reserved d: and a local drive f:, which are both internal drives.

I can continue accessing the Toshiba drive, now drive t:, from Windows Explorer as well as by entering t: into the run dialog box.

As you say it is very mysterious.

Microsoft Defender is my only security software installed and running.

The external drive, btw, has more than enough space. Windows Explorer reports 1.24 TB free out of 1.36 TB.


David Goldfield,
Blindness Assistive Technology Specialist
JAWS Certified, 2019

WWW.DavidGoldfield.org
On 9/6/2020 3:51 PM, Brian Vogel wrote:
David,

           I just want to be absolutely clear, when you open File History, and activate the Select Drive link, when that drive is connected to the computer and visible in File Explorer it is not showing up in the list of available drives?

Mickey,

You're quite welcome.

--

Brian - Windows 10 Pro, 64-Bit, Version 2004, Build 19041

A man's worst difficulties begin when he is able to do as he likes.

       ~ Thomas H. Huxley (1876)