Topics

Edge 79: if your screen reader is having trouble working with web content shown in Edge... #chromiumedge


 

Hi all,

 

Someone reported on JFW list (hosted on Groups.IO) that the user cannot interact with certain web content displayed in Edge 79 beta, along with a thread on Win10 forum about inability to interact with web content shown in Edge with other screen readers. This issue can be traced to the fact that, in Edge 79 (upcoming stable version), UI Automation is enabled (several reports were sent to Microsoft about this issue). Unfortunately, as an NVDA core developer (not me) notes, UIA implementation in Chromium-based web browsers (including Edge) isn’t solid yet.

 

To work around this for now, you need to disable UIA support in Edge and other Chromium-based web browsers (if your browser exposes this option). To do so in Edge 79:

 

  1. Start new Microsoft Edge (not the old one).
  2. From address omnibox (Alt+D), type “edge://flags” (without quotes and as exactly as shown) and press Enter.
  3. Type “UI Automation” into “search flags” and press Tab to move through resulting content (no, DO NOT PRESS ENTER AFTER TYPING FLAGS!).
  4. Go to “Native UI Automation” combo box and select “disabled”.
  5. Press Tab to go to “Restart” button and click it.

 

Screen reader specifics:

 

  • Narrator: supports native UI Automation
  • JAWS: works better with native UI Automation off
  • NVDA: works better with UI Automation off and a fix is being developed
  • Other screen readers: contact vendors

 

Cheers,

Joseph


Gerardo Corripio
 

Finally finally! Now I know I’m not crazy in not being able to interact via the keyboard with Edge! I tried it out yesterday, hoping they’d updated i, but no go ! thanks for the tip on turning off the automation! Thus when the new Edge is released, will it default to on, or will we need to revert the process you described?

Gera
Enviado desde mi iPhone SE de Telcel

El 13 ene 2020, a la(s) 12:25 a.m., Joseph Lee <joseph.lee22590@...> escribió:



Hi all,

 

Someone reported on JFW list (hosted on Groups.IO) that the user cannot interact with certain web content displayed in Edge 79 beta, along with a thread on Win10 forum about inability to interact with web content shown in Edge with other screen readers. This issue can be traced to the fact that, in Edge 79 (upcoming stable version), UI Automation is enabled (several reports were sent to Microsoft about this issue). Unfortunately, as an NVDA core developer (not me) notes, UIA implementation in Chromium-based web browsers (including Edge) isn’t solid yet.

 

To work around this for now, you need to disable UIA support in Edge and other Chromium-based web browsers (if your browser exposes this option). To do so in Edge 79:

 

  1. Start new Microsoft Edge (not the old one).
  2. From address omnibox (Alt+D), type “edge://flags” (without quotes and as exactly as shown) and press Enter.
  3. Type “UI Automation” into “search flags” and press Tab to move through resulting content (no, DO NOT PRESS ENTER AFTER TYPING FLAGS!).
  4. Go to “Native UI Automation” combo box and select “disabled”.
  5. Press Tab to go to “Restart” button and click it.

 

Screen reader specifics:

 

  • Narrator: supports native UI Automation
  • JAWS: works better with native UI Automation off
  • NVDA: works better with UI Automation off and a fix is being developed
  • Other screen readers: contact vendors

 

Cheers,

Joseph


 

Hi,

It’ll be enabled, according to reports from a number of sources.

Also, a huge news: if you are using NVDA 2019.3 or later, you can safely ignore the workaround notice, as NVDA itself will resort to using a method known to work better with Chromium-based browsers (it’ll use IAccessible2).

Cheers,

Joseph

 

From: win10@win10.groups.io <win10@win10.groups.io> On Behalf Of Gerardo Corripio
Sent: Monday, January 13, 2020 6:30 AM
To: win10@win10.groups.io
Subject: Re: [win10] Edge 79: if your screen reader is having trouble working with web content shown in Edge... #ChromiumEdge

 

Finally finally! Now I know I’m not crazy in not being able to interact via the keyboard with Edge! I tried it out yesterday, hoping they’d updated i, but no go ! thanks for the tip on turning off the automation! Thus when the new Edge is released, will it default to on, or will we need to revert the process you described?

Gera

Enviado desde mi iPhone SE de Telcel



El 13 ene 2020, a la(s) 12:25 a.m., Joseph Lee <joseph.lee22590@...> escribió:



Hi all,

 

Someone reported on JFW list (hosted on Groups.IO) that the user cannot interact with certain web content displayed in Edge 79 beta, along with a thread on Win10 forum about inability to interact with web content shown in Edge with other screen readers. This issue can be traced to the fact that, in Edge 79 (upcoming stable version), UI Automation is enabled (several reports were sent to Microsoft about this issue). Unfortunately, as an NVDA core developer (not me) notes, UIA implementation in Chromium-based web browsers (including Edge) isn’t solid yet.

 

To work around this for now, you need to disable UIA support in Edge and other Chromium-based web browsers (if your browser exposes this option). To do so in Edge 79:

 

  1. Start new Microsoft Edge (not the old one).
  2. From address omnibox (Alt+D), type “edge://flags” (without quotes and as exactly as shown) and press Enter.
  3. Type “UI Automation” into “search flags” and press Tab to move through resulting content (no, DO NOT PRESS ENTER AFTER TYPING FLAGS!).
  4. Go to “Native UI Automation” combo box and select “disabled”.
  5. Press Tab to go to “Restart” button and click it.

 

Screen reader specifics:

 

  • Narrator: supports native UI Automation
  • JAWS: works better with native UI Automation off
  • NVDA: works better with UI Automation off and a fix is being developed
  • Other screen readers: contact vendors

 

Cheers,

Joseph