Topics

If your braille display isn't working with your screen reader, try this #nvdasr #jaws #narrator #braille


Devin Prater
 

Hi all. Today, I tried to get a Focus 40, Fifth generation to work with NVDA. I’d previously tried out an Actilino, with all major screen readers, including Narrator. NVDA couldn’t connect to the Focus 40, and neither could JAWS. So, on a hunch, I went to Narrator settings and to the braille section, and changed the driver away from the Narrator version.

So, if you have this problem, try the following:
Open Settings with Windows+I
Tab once to the list of settings categories, then Arrow right to “Ease of Access”
Arrow down to “Narrator” and pressEnter
Tab to “Use driver”, and arrow to an option that doesn’t have “Narrator” in it.
Now, you can close settings, and try to connect to your braille display again.

Windows accessibility folks:
While Braille in Narrator is a wonderful thing, I do wish the usage of BRLTTY wasn’t required for that. That just adds driver complexity with other screen readers, to me. I’d suggest, at least, that whenever a braille display is connected, a toast appear telling the user that the Narrator driver is in use. Having the Narrator driver simple take over the whole use of the device working with the computer is pretty invasive, and no other screen readers know about it, only that they can’t access the device.

So, hopefully this has helped some one. And all who are in tech support for braille displays, keep this in mind if a user has a problem with connected to a PC with JAWS or NVDA, any third-party screen reader.


 

Hi,
The fastest way to get to Narrator settings screen is Control+Windows+N.
Cheers,
Joseph

-----Original Message-----
From: win10@win10.groups.io <win10@win10.groups.io> On Behalf Of Devin Prater
Sent: Thursday, July 11, 2019 8:22 AM
To: win10@win10.groups.io
Subject: [win10] If your braille display isn't working with your screen reader, try this #Narrator #braille #NVDA #JAWS

Hi all. Today, I tried to get a Focus 40, Fifth generation to work with NVDA. I’d previously tried out an Actilino, with all major screen readers, including Narrator. NVDA couldn’t connect to the Focus 40, and neither could JAWS. So, on a hunch, I went to Narrator settings and to the braille section, and changed the driver away from the Narrator version.

So, if you have this problem, try the following:
Open Settings with Windows+I
Tab once to the list of settings categories, then Arrow right to “Ease of Access”
Arrow down to “Narrator” and pressEnter
Tab to “Use driver”, and arrow to an option that doesn’t have “Narrator” in it.
Now, you can close settings, and try to connect to your braille display again.

Windows accessibility folks:
While Braille in Narrator is a wonderful thing, I do wish the usage of BRLTTY wasn’t required for that. That just adds driver complexity with other screen readers, to me. I’d suggest, at least, that whenever a braille display is connected, a toast appear telling the user that the Narrator driver is in use. Having the Narrator driver simple take over the whole use of the device working with the computer is pretty invasive, and no other screen readers know about it, only that they can’t access the device.

So, hopefully this has helped some one. And all who are in tech support for braille displays, keep this in mind if a user has a problem with connected to a PC with JAWS or NVDA, any third-party screen reader.


Devin Prater
 

Ah, thanks. I thought that only worked when Narrator is on.

On Jul 11, 2019, at 10:33 AM, Joseph Lee <joseph.lee22590@gmail.com> wrote:

Hi,
The fastest way to get to Narrator settings screen is Control+Windows+N.
Cheers,
Joseph

-----Original Message-----
From: win10@win10.groups.io <win10@win10.groups.io> On Behalf Of Devin Prater
Sent: Thursday, July 11, 2019 8:22 AM
To: win10@win10.groups.io
Subject: [win10] If your braille display isn't working with your screen reader, try this #Narrator #braille #NVDA #JAWS

Hi all. Today, I tried to get a Focus 40, Fifth generation to work with NVDA. I’d previously tried out an Actilino, with all major screen readers, including Narrator. NVDA couldn’t connect to the Focus 40, and neither could JAWS. So, on a hunch, I went to Narrator settings and to the braille section, and changed the driver away from the Narrator version.

So, if you have this problem, try the following:
Open Settings with Windows+I
Tab once to the list of settings categories, then Arrow right to “Ease of Access”
Arrow down to “Narrator” and pressEnter
Tab to “Use driver”, and arrow to an option that doesn’t have “Narrator” in it.
Now, you can close settings, and try to connect to your braille display again.

Windows accessibility folks:
While Braille in Narrator is a wonderful thing, I do wish the usage of BRLTTY wasn’t required for that. That just adds driver complexity with other screen readers, to me. I’d suggest, at least, that whenever a braille display is connected, a toast appear telling the user that the Narrator driver is in use. Having the Narrator driver simple take over the whole use of the device working with the computer is pretty invasive, and no other screen readers know about it, only that they can’t access the device.

So, hopefully this has helped some one. And all who are in tech support for braille displays, keep this in mind if a user has a problem with connected to a PC with JAWS or NVDA, any third-party screen reader.





Shou-Ching Schilling
 

Hi Devin, can you submit the Narrator braille suggestion using the Feedback hub?  Thanks!
--
Thanks,
Shou-Ching Schilling
Windows Accessibility Community Champ